No start fuel issue - flow but no pressure- SOLVED


A quick write-up on an issue we chased for a while only to find a unique cause that we hadn’t encountered before.

We have a 1991 SE30 325i and were doing some upgrades/preventative maintenance over the winter. One of the projects was to replace the old fuel pump with a new one as the old pump was probably 10-20 years old. We also did new wiring in the engine compartment and dash so there were a few other variables in the mix. Once we had everything installed, we tried to start the car but it wouldn’t start so we went down the troubleshooting rabbit hole.

A few sites were very helpful with a decision tree to help logically go through this process:

We followed the eeuroparts sirte fairly closely and quickly ruled out an electrical issue. Spark plugs, wires, coil all had good spark using the hold a screwdriver close trick (and don’t get zapped). Next was the CPS as it was easy to get to and test ohms. Coil was next and interestingly, the coil spec is 0.5ohms and our cheap multimeter read 0.9 ohms. We forgot to subtract the multimeter resistance (touch both leads together and subtract that reading from the final reading on the coil). That came to 0.6 ohms which was close enough. This may have also been a factor of a cheap multimeter so need to invest in a better one in the future. Next was testing fuel flow. We disconnected the input and output fuel lines from the fuel pressure regulator (FPR) and rail and tested flow. We had flow into the rail but not out of the FPR. At least we knew the pump of pumping fuel but didn’t know pressure so we bought a $23 fuel pressure tester at Harbor Freight and tested pressure between the input hose to the fuel rail and the fuel rail using sections of hose from the kit. Worked great and showed we had very little (under 5 psi) pressure. Flow with no pressure… that was a new one for us. We then tested fuel pressure at the fuel pump to eliminate any otehr variables like the fuel filter being in backwards or other blockages. Still flow but no pressure. We then pulled the fuel pump out and inspected the pump. Upon inspection we found that the plastic piece that connects to the top of the pump was cracked which explains why we had flow but no pressure. Swapped pumps and problem solved.

Hope this helps